SDK for Windows Software

GP-C830 Series

Patch program for privilege escalation vulnerability of EPSON Network Utility


New release.
1.Note
This is a patch program to fix the vulnerability issue. (Relevant products are listed in [3. Affected Products])
[About the vulnerability issue]
The EPSON Network utility included with some older Epson printers installs a binary with weak permissions, which can allow a low privilege user to escalate their privileges and take control of the system. Successful exploitation of this vulnerability can lead to unauthorized control of the system by a low privilege user.

2.Supported Environment (OS)
Windows 10 (32/64bit)
Windows 8.1 (32/64bit)
Windows 8 (32/64bit)
Windows 7 (32/64bit)
Windows Vista (32/64bit)
Windows XP (32/64bit)
Windows 2000

3.Affected Products
GP-C830,GP-C831,GP-C832,GP-M800,GP-M830,GP-M831,GP-M832,TM-C3400,TM-C3500,TM-C3510,TM-C3520,TM-C7500,TM-C7510,TM-C7520,TM-C7500G,TM-C7510G,TM-C7520G

4.Affected Contents
Printer Driver for TM-C3400 Ver.1.5.0.0 or earlier
Printer Driver for TM-C3500/C3510/C3520 Ver.1.1.0.3 or earlier
TM-C35x0 Compressed data Driver Ver.1.0.0.5 or earlier
TM-C3500 Series Install Navi Ver.1.1.0.1 or earlier
Epson Inkjet Label Printer SDK (TM-C3400, TM-C3400BK, TM-C3500 Series, TM-C7500 Series, TM-C7500G Series) Ver.1.01 or earlier
EPSON Monitoring Tool Ver.1.50 or earlier

  • 10
  • 8.1
  • 8
  • 7
  • Vista
  • XP
  • 2000

Jump to the top